Arbiter(HDU 3118)---二进制枚举+去边构造二分图

题目链接

题目描述

Arbiter is a kind of starship in the StarCraft science-fiction series. The Arbiter-class starship is a Protoss warship specializing in providing psychic support. Arbiters were crewed exclusively by Judicators; unlike other warships that were manned predominantly by Templar. The Judicator used the Arbiter as a base to provide support using space-time manipulation.
Arbiters could weaken space-time, tearing rifts in the fabric of space-time, creating a vortex linking another location to the Arbiter’s location. This could be used to move personnel over long distances between stars.
In the meantime of widely used Arbiter to transfer, KMXS, the captain of one Arbiter, was warning that some person had got a serious mental disorder after the trip on his Arbiter. By using mice as model animals, he found the sake, it’s because of chirality!
Every person has chirality, either left-handed or right-handed. Actually all the persons must live with the food which has the same chirality. When one person took Arbiter from one star to another one, his chirality will be changed (from left-handed to right-handed or from right-handed to left-handed). If a person took a long trip and finally got back to his own star, however, his chirality might be changed to the opposite state other than his original, which would cause fatal mental disorder, or even death.
KMXS has the channels map among the starts and he need to prohibit minimum number of channels from traveling so that wherever a person starts his traveling from when he gets his original star he’ll be safe. KMXS turns to your help.

输入格式

The first line of input consists of an integer T, indicating the number of test cases.
The first line of each case consists of two integers N and M, indicating the number of stars and the number of channels. Each of the next M lines indicates one channel (u, v) which means there is a bidirectional channel between star u and star v (u is not equal to v).

输出格式

Output one integer on a single line for each case, indicating the minimum number of channels KMXS must prohibit to avoid mental disorder.
Constraints
0 < T <= 10
0 <= N <= 15 0 <= M <= 300
0 <= u, v < N and there may be more than one channel between two stars.

输入样例

1
3 3
0 1
1 2
2 0

输出样例

1

分析

题目大意是给出n个点m条边的无向图,求最少去掉几条边原图能构成无向图。
对于这道题,由于n≤15,所以可以枚举所有可能染色的情况最多共2^15种情况,对于每一种情况,我们将同色的边删去(二进制没有奇数环),找到所有删除情况的最小值即可,以下是源代码。

源程序

Prim算法

#include <bits/stdc++.h>
#define MAXN 20
#define INF 0x3f3f3f3f
using namespace std;
int t,n,m,g[MAXN][MAXN];
int del(int k)
{
	int num=0;	//删边数
	for(int i=0;i<n;i++){
		for(int j=i+1;j<n;j++){
			if((k&(1<<i))==0 && (k&(1<<j))==0)	//i和j同属一个集合
				num+=g[i][j]; 
			else if((k&(1<<i))!=0 && (k&(1<<j))!=0)	//i和j同属另一个集合
				num+=g[i][j]; 
		}
	} 
	return num;
}
int main()
{
	scanf("%d",&t);
	while(t--){
		memset(g,0,sizeof(g));
		scanf("%d%d",&n,&m);
		if(n==0||m==0){	
			printf("0\n");
			continue;
		}
		for(int i=1;i<=m;i++){	//建图 
			int u,v;
			scanf("%d%d",&u,&v);
			g[u][v]++,g[v][u]++;
		}
		int res=INF;
		for(int i=0;i<(1<<n);i++)	//枚举每种可能,共2^n种 
			res=min(res,del(i));
		printf("%d\n",res);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值