Is It A Tree?(HDU 1325)---并查集+树知识

题目链接

题目描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
在这里插入图片描述在这里插入图片描述在这里插入图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入格式

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

输出格式

For each test case display the line Case k is a tree." or the lineCase k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

输入样例

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

输出样例

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

分析

这道题主要注意以下几种情况:
一、连通图。

  1. 图无根节点,此时该图为环图,不是一颗树,如图①。
  2. 图有一个根节点,此时有两种情况。第一种是除根节点外,其他点的入度为1,满足树的要求,如图②。第二种是图内至少存在一个点的入度大于1,此时不是一颗树,如图③。
  3. 图有多个根节点,不是一颗树,如图④。

二、非连通图,即森林,如图⑤。
在这里插入图片描述
另外,需要注意本题结束测试的条件是输入均为负数,不是-1,我在这上面wa了几次才注意到!!!

源程序

#include <bits/stdc++.h>
#define MAXN 100005
using namespace std;
int u,v,degree[MAXN],father[MAXN],num[MAXN];
int find(int x)	//并查集 
{
	if(x==father[x]) return x;
	return father[x]=find(father[x]);
}
void Union(int x,int y)	//合并 
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
		father[fx]=fy;
}
int main()
{
	int cas=0;	//记录测试点数 
	while(~scanf("%d%d",&u,&v)&&u>=0&&v>=0){
		if(u==0&&v==0){
			printf("Case %d is a tree.\n",++cas);
			continue;
		}
		for(int i=0;i<MAXN;i++)father[i]=i,degree[i]=0;	//初始化 
		set<int> s;
		do{
			s.insert(u),s.insert(v);
			Union(u,v);
			degree[v]++;
		}while(~scanf("%d%d",&u,&v)&&u&&v);
		int cnt=0;	//记录连通分量数
		int root=-1,rootnum=0;	//记录根节点和根节点数 
		set<int>::iterator it;
		for(it=s.begin();it!=s.end();it++){	
			if(father[*it]==*it)
				cnt++;
			if(degree[*it]==0)	//记录根节点
				root=*it,rootnum++; 
		}
		if(cnt==1){	//连通图 
			if(root==-1){	//环图无根节点 
				printf("Case %d is not a tree.\n",++cas);
				continue;
			}
			bool flag=true;	//判断是否为树 
			for(it=s.begin();it!=s.end();it++){
				if(degree[*it]>1)	//节点入度>1则标记不是树 
					flag=false;
			}
			if(rootnum>1)flag=false;	//不止一个根 
			if(flag)
				printf("Case %d is a tree.\n",++cas);
			else
				printf("Case %d is not a tree.\n",++cas);
		}
		else	//非连通图 
			printf("Case %d is not a tree.\n",++cas);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值