寒假训练9-h

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes with various lengths. Each driver is assigned one morning route and one evening route. For any driver, if his total route length for a day exceeds d, he has to be paid overtime for every hour after the first d hours at a flat r taka / hour. Your task is to assign one morning route and one evening route to each bus driver so that the total overtime amount that the authority has to pay is minimized.
Input
The first line of each test case has three integers n, d and r, as described above. In the second line, there are n space separated integers which are the lengths of the morning routes given in meters. Similarly the third line has n space separated integers denoting the evening route lengths. The lengths are positive integers less than or equal to 10000. The end of input is denoted by a case with three 0’s.
Output
For each test case, print the minimum possible overtime amount that the authority must pay.
Constraints

• 1 ≤ n ≤ 100

• 1 ≤ d ≤ 10000

• 1 ≤ r ≤ 5
Sample Input
2 20 5

10 15

10 15

2 20 5

10 10

10 10

0 0 0
Sample Output
50

0

问题简述:有n个司机,分别给每个司机分配一条早上的路线与晚上的路线,每条路线均有时长,当司机一天工作时长超过d时,超过时间按每小时r元算,求给出超时费用最少时的费用

问题分析:不难发现,当给一个司机分配早上最长的路线与晚上最短的路线,可使费用最少,以此类推,局部最优解可以推出整体最优解,属于贪心问题。

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[200], b[200], sum[200];
int cmp1(int a, int b)
{
	return a < b;
}
int cmp2(int a, int b)
{
	return a > b;
}
int main()
{
	int n, d, r, sum1;
	while (cin >> n >> d >> r)
	{
		if (n == 0 && d == 0 && r == 0)break;
		sum1 = 0;
		for (int i = 0; i < n; i++)
			cin >> a[i];
		for (int j = 0; j < n; j++)
			cin >> b[j];
		sort(a, a + n, cmp1);
		sort(b, b + n, cmp2);
		for (int t = 0; t < n; t++)
		{
			sum[t] = a[t] + b[t];
			if (sum[t] > d)
				sum1 += r * (sum[t] - d);
		}
		cout << sum1 << endl;
	}
	return 0;
}//ac

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值