Bin Packing UVA - 1149

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same
length l and each item i has length li ≤ l. We look for a minimal number of bins q such that
• each bin contains at most 2 items,
• each item is packed in one of the q bins,
• the sum of the lengths of the items packed in a bin does not exceed l.
You are requested, given the integer values n, l, l1, . . . , ln, to compute the optimal number of bins
q.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The first line of the input file contains the number of items n (1 ≤ n ≤ 105
). The second line
contains one integer that corresponds to the bin length l ≤ 10000. We then have n lines containing one
integer value that represents the length of the items.
Output
For each test case, your program has to write the minimal number of bins required to pack all items.
The outputs of two consecutive cases will be separated by a blank line.
Note: The sample instance and an optimal solution is shown in the figure below. Items are numbered
from 1 to 10 according to the input order.
Sample Input
1
10
80
70
15
30
35
10
80
20
35
10
30
Sample Output
6

思路:先对数据排序,对每一个目前最大值找到可以最大程度匹配的值,若找不到,则自己装到一个背包

#include <iostream>
#include<algorithm>
using namespace std;
int a[100005];
int main()
{
	int t, n, max, sum;
	cin >> t;
	while (t--)
	{
		int a[100001];
		sum = 0;
		cin >> n >> max;
		for (int i = 0; i < n; i++) cin >> a[i];
		sort(a, a + n);
		for (int i = n - 1; i >= 0; i--)
		{
			if (a[i] == 0) continue;
			for (int j = i - 1; j >= 0; j--)
			{
				if (a[j] == 0) continue;
				if (a[i] + a[j] <= max)
				{
					a[j] = 0;
					break;
				}
			}
			a[i] = 0;
			sum++;
		}
		cout << sum << endl;
		if (t) cout << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值