1098 Insertion or Heap Sort (25 point(s)) PAT甲级

1098 Insertion or Heap Sort (25 point(s))

插入排序、堆排序

题目

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

思路

题意

给出n个整数,采用插入排序或堆排序,升序输出排序过程中的数字,推断是插入排序还是堆排序,并给出相应的下一步结果。

分析

插入排序是从前往后逐渐扩大有序串的大小,排序到第i步的时候前i个数字是按照从小到大的顺序排列的,后面则和原数序一样。所以只要找到小于前一个数字的数,比较之后的数字是否与原数组相同即可判断是否是插入排序。如果是插入排序,得到下一步就是排列好i+1个数字,可以直接用sort()函数对前i+1个数进行排序。

根据题意,不是插入排序就一定是堆排序。如果是堆排序,则是在已经建立好的最大堆中,不断选出最顶端的大数丢到数组末尾去。所以数组后面已经排好顺序的数字是从小到大的,前面是最大堆,第一个数字比未排好序的数字都大。所以从后往前遍历数组,找到比第一个数字小的数字,这个位置i就是当前的最大堆的最后一个位置。交换第一个数和该数的值,按照最大堆的原理来处理前面i个数字的顺序即可得到下一步结果。

代码

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int main()
{
	int n, t;
	bool isInsert = true;
	scanf("%d", &n);
	vector<int> a(n), b(n);
	for (int i = 0; i < n; ++i)
		scanf("%d", &a[i]);
	for (int i = 0; i < n; ++i)
		scanf("%d", &b[i]);
	for (t = 1; t < n; ++t)
		if (b[t] < b[t-1]) break;
	for(int i = t; i < n; ++i)
		if (a[i] != b[i]) {
			isInsert = false;
			break;
		}
	if (isInsert) {
		printf("Insertion Sort\n");
		sort(b.begin(), b.begin() + t + 1);
	}
	else {
		printf("Heap Sort\n");
		for (t = n - 1; t >= 0; --t)
			if (b[t] < b[0]) break;
		swap(b[t], b[0]);
		int i = 0, j = i * 2 + 1;
        while (j <= t-1) {
            if (j + 1 <= t-1 && b[j] < b[j + 1]) j = j + 1;
            if (b[i] > b[j]) break;
            swap(b[i], b[j]);
            i = j; j = i * 2 + 1;
        }
	}
	for (int i = 0; i < n; ++i)
		printf("%d%s", b[i], i == n - 1 ? "\n" : " ");

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值