1099 Build A Binary Search Tree (30 point(s)) PAT甲级

1099 Build A Binary Search Tree (30 point(s))

BST,树的遍历

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

思路

题意

有一颗二叉搜索树,下标为0~n-1,0为根节点。给出n个结点的孩子结点信息,-1代表孩子不存在。给出n个数字,把这n个数字填入二叉搜索树中,层序输出结果。

分析

用二维数组存储树的结构,tree[index][0]代表index结点的左孩子,tree[index][1]代表index结点的右孩子。

因为中序遍历二叉搜索树得到的结果是从小到大排列的数字,所以用vector类存储结点,排序后中序遍历树的同时给结点赋值即可得到二叉搜索树。用队列层序输出结果。

代码

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

int tree[105][2], node[105], index = 0;
vector<int> v;

void BST(int root) {//inorder
	if (root == -1) return;
	BST(tree[root][0]);//left tree
	node[root] = v[index++];
	BST(tree[root][1]);//right tree
}

int main()
{
	int n, temp;
	queue<int> q;
	scanf("%d", &n);
	v.resize(n);
	for (int i = 0; i < n; ++i)
		scanf("%d%d", &tree[i][0], &tree[i][1]);
	for (int i = 0; i < n; ++i)
		scanf("%d", &v[i]);
	sort(v.begin(), v.end());
	BST(0);
	q.push(0);
	while (!q.empty() && n--) {
		temp = q.front();
		printf("%d%s", node[temp], n == 0 ? "\n" : " ");
		q.pop();
		if (tree[temp][0] > 0) q.push(tree[temp][0]);
		if (tree[temp][1] > 0) q.push(tree[temp][1]);
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值