1077 Kuchiguse (20 point(s)) PAT甲级

1077 Kuchiguse (20 point(s))

字符串

题目

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

思路

题意

口癖是每句话结尾都说一样的尾缀。给出数字n,给出n行字符串,判断它们是否拥有同样的口癖(尾缀)。如果有,输出该口癖;如果没有,输出“nai”;

分析

需要输入每行字符串,不需要得到换行符,用getline(cin,str)来得到字符串。(getline()会抛弃换行符,用get()会保留换行符,需要多调用一次)。每次得到的一行字符串用reverse(str.begin(), str.end())来反转,这样只要比较前几个字符是否相等就可以。每次比较两个字符串从前往后(已颠倒)的最大数目的相等字符串即可得到最终结果。最后记得翻转ans。

如果最后ans的长度为0,则没有相同的口癖,用if判断。

分析

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
	int n;
	string s, ans;
	scanf("%d\n", &n);
	for (int i = 0; i < n; ++i) {
		getline(cin, s);
		reverse(s.begin(), s.end ());
		if (i == 0) ans = s;
		else {
			ans = s.length() < ans.length() ? s : ans;
			int len = ans.length();
			for (int j = 0; j < len; ++j) {
				if (s[j] != ans[j]) {
					ans = s.substr(0, j);
					break;
				}
			}
		}
	}
	reverse(ans.begin(), ans.end());
	if (ans.length() == 0) printf("nai\n");
	else printf("%s\n", ans.c_str());
	return 0;
}

注意

  • 读取n的时候要换行,不然接下来第一个读到的一行是n后的换行符。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值