Integer Inquiry UVA - 424

Text Reverse
Time limit: 3.000 seconds

Problem Description
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger.
Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

问题链接
UVA - 424

问题简述:
给你不到一百行的“非常长的正整数”(该整数不超过一百位)进行加法运算。

问题分析:
高精度多项式加法
高精度运算内容可以参考这个博客
程序说明:
设定两个字符串数组A,B,A为每次输入的“非常长的整数”,B为之前的“非常长的整数”之和,即:

B=0    
cin>>A  
B+=A   
cin>>A  
B+=A
……

不断循环,直至输入0为止
注意数组长度适量放宽

#include <cstring>
#include <ctime>
#include <iostream>
#include <iomanip>
#include <cmath>
#include <algorithm>
#include <stdlib.h>
using namespace std;

int main()
{
	int b[150],d,i;
	char a[105];
	memset(b,0,sizeof(b));
	while(cin>>a)
	{
	    if(a[0]=='0')
	    break;
	    
    for(i=1;i<=strlen(a);i++)
    {
	    b[i]+=a[strlen(a)-i]-'0'; 
	    if (b[i]>=10)
	    {
	    	d=b[i];
	    	b[i]=d%10;
	    	b[i+1]+=d/10;
		}
    } 
	memset(a,0,sizeof(a)) ; 
}

for (i = 105; i >= 1; i--)
	if (b[i])
		break;
for(;i>0;i--)
cout<<b[i];
cout<<endl;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值