POJ - 3984 迷宫问题 (DFS)

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
问题链接http://poj.org/problem?id=3984
问题分析:DFS+存储路径,记录步数,在每个DFS回溯之前用一个结构体存储路径即可。(记录的是(0,0)后的步数,所以应在输出路径前输出起点(0, 0)。(注意输出 “ , ”后面还有一个空格)
AC通过的C++语言程序如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
const int N = 100;
bool pd[N][N] = { 0 };
int maze[N][N] = { 0 };
int dir[4][2] = { 0,1,1,0,0,-1,-1,0 };
int step;
struct lu
{
	int x, y;
}path[20];
int a = 0;
int t = 0;
bool checkedge(int x, int y)
{
	if (pd[x][y] != 1 && x < 5 && y < 5 && x >= 0 && y >= 0 && maze[x][y] != 1)
	{
		return 1;
	}
	else return 0;
}
void dfs(int x, int y)
{
	pd[x][y] = 1;
	if (x == 4 && y == 4)
	{
		step = a;
		return;
	}
	for (int i = 0; i < 4; i++)
	{
		if (checkedge(x + dir[i][0], y + dir[i][1]))
		{
			path[a].x = x + dir[i][0];
			path[a].y = y + dir[i][1];
			a++;
			dfs(x + dir[i][0], y + dir[i][1]);
		}
	}
	return;
}
int main()
{
	for (int i = 0; i < 5; i++)
	{
		for (int j = 0; j < 5; j++)
		{
			cin >> maze[i][j];
		}
	}
	dfs(0, 0);
	cout<< "(" << 0 << ", " << 0 << ")" << endl;
	for (int i = 0; i <step; i++)
	{
		cout << "(" << path[i].x << ", " << path[i].y << ")" << endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值