M-sekiro

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying amount of money, the amount of money will be reduced to , where indicates the smallest integer that .

As a noobie of the game, BaoBao has died times in the game continuously. Given that BaoBao carried amount of money before his first death, and that BaoBao didn’t collect or spend any money during these deaths, what’s the amount of money left after his deaths?

Input
There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers and (, ), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output
For each test case output one line containing one integer, indicating the amount of money left after deaths.

Sample Input
4
10 1
7 1
10 2
7 2
Sample Output
5
4
3
2
Hint
For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.
此题数据太大,10的九次方使用for循环会导致错误,所以可以转换思路,对原有的金钱进行开方。另一个易错点是当原有的金钱为1或0时,要终止循环,0或1对2向上取整永远都是0或1,其他的问题就能迎刃而解了。

#include <bits/stdc++.h>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
using namespace std;
int main()
{
    int t;
    long long n,k,c,d,e;
    scanf("%d",&t);
    while( t-- )
    {
        scanf("%lld%lld",&n,&k);
        c=sqrt(n);//对狼的原有金钱进行开方
        c=c+1;//向上取整
        if(n==0)
        {printf("0\n");
            continue;}//当狼的金钱数为0时跳出此次循环
        if(k>=c)
        {printf("1\n");}//当k>c时,对c进行k次对2向上取整最后结果都会为1
        else
        {
            while( k-- )
            {
            if(n==1)
            {break;}
            if(n%2==0)
            {n=n/2;
            continue;}
            if(n%2!=0)
            {n=n/2+1;
            continue;}
            }
            printf("%lld\n",n);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值