Problem Description
已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
Input
输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。
Output
输出二叉树的先序遍历序列
Sample Input
2
dbgeafc
dgebfca
lnixu
linux
Sample Output
abdegcf
xnliu
Hint
Source
GYX
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct tree
{
struct tree *left,*right;
int data;
};
struct tree *creat(int len,char a[],char b[])
{
if(len<=0)return NULL;
struct tree *t;
t=(struct tree *)malloc(sizeof(struct tree));
t->data=b[len-1];
int i;
for(i=0; i<len; i++)
{
if(a[i]==b[len-1])break;
}
t->left=creat(i,a,b);
t->right=creat(len-i-1,a+i+1,b+i);
return t;
}
void backshow(struct tree *t)
{
if(t==NULL) return;
printf("%c",t->data);
backshow(t->left);
backshow(t->right);
}
int main()
{
int len,T;
char a[55],b[55];
struct tree *root;
scanf("%d",&T);
while(T--)
{
scanf("%s %s",a,b);
len=strlen(a);
root=creat(len,a,b);
backshow(root);
printf("\n");
}
return 0;
}