PAT甲级 A1038

PAT甲级 A1038

题目详情

1038 Recover the Smallest Number (30分)
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10e4 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

思路分析

这道题本来以为是一个比较简单的题目,但后来发现其实没有我想的那么简单。最初的想法就是把所有的数据按照string类型存成一个vector向量,把向量中按照sort进行排序,排序的规则为:两个字符串a,b,如果a,b位数相同,就直接return a<b;如果a,b位数不相同,先通过其首位按位判断大小。这样是纯暴力算法。后来还是参考了柳婼前辈(指路https://blog.csdn.net/liuchuo/article/details/52264827?utm_medium=distribute.pc_relevant_right.none-task-blog-BlogCommendFromMachineLearnPai2-4.nonecase&depth_1-utm_source=distribute.pc_relevant_right.none-task-blog-BlogCommendFromMachineLearnPai2-4.nonecase:)思想,直接return a+b<b+a,茅塞顿开
AC代码:

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
using namespace std;
vector<string> n1;
int N;
bool cmp(string a, string b) {
	return a + b < b + a;
}
int main() {
	cin >> N;
	for (int i = 0; i < N; i++) {
		string temp;
		cin >> temp;
		n1.push_back(temp);
	}
	sort(n1.begin(), n1.end(),cmp);
	string temp = "";
	for (int i = 0; i < n1.size(); i++) {
		temp += n1[i];
	}
	int judge = 0;
	for (int i = 0; i < temp.size(); i++) {
		if (temp[i] == '0' && judge == 0) {
			continue;
		}
		if (temp[i] != '0' && judge == 0) {
			judge = 1;
		}
		cout << temp[i];
	}
	if (judge == 0) {
		cout << 0 << '\n';
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值