Maximum Sum UVA - 108

Maximum Sum

 UVA - 108 

Time limit    3000 ms

 

题目描述:

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle.

A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array:

                                  0     −2     −7       0

                                  9       2     −6       2

                                −4       1     −4       1

                                −1       8        0     −2

is in the lower-left-hand corner:

                                  9      2

                                −4      1

                                −1      8

and has the sum of 15.

Input

The input consists of an N × N array of integers.

The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127].

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

   4

   0     −2     −7       0

   9       2     −6       2

 −4       1     −4       1

 −1       8        0     −2

Sample Output

15

思路如下:

在做这道题之前可以先看

最大连续子序列 HDU - 1231

https://cn.vjudge.net/problem/HDU-1231

这个一维的最大连续子序列的用法,就在二维变一维的时候用到的思想来求最大值。

这个题主要是如何把二维变成一维的方式来求,然后就是求其最大连续子序列。

代码如下:

#include<stdio.h>
#include<string.h>
int n,a[130][130],s[120],max;
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf("%d",&a[i][j]);
        max=-1;                //找最大,肯定大于0,初始化为-1
        for(int i=0;i<n;i++)
        {
            memset(s,0,sizeof(s));     //初始化数组
            for(int j=i;j<n;j++)
            {
                int sum=0;
                for(int k=0;k<n;k++)
                {
                    s[k]+=a[j][k];//每列之间层层相加,把一维变二维的方式来求
                    if(sum>=0)        //sum大于等于0相加必然会比之前的增加或者不变
                        sum+=s[k];    
                    else              
                        sum=s[k];
                    if(sum>max)        //出现sum大于max最大值,则更新最大值max
                        max=sum;
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值