poj 3070(矩阵快速幂)

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.在这里插入图片描述

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875
Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.在这里插入图片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.在这里插入图片描述
题意:一道矩阵快速幂,开数组计算的话肯定不行,范围太大了,数组没有那么大,应该是只有矩阵快速幂可以做了,如果是初学快速幂的话可以看下这篇博客 https://blog.csdn.net/qq_40061421/article/details/82625338 ,其它的正常操作应该就能做出来了

#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stdio.h>
using namespace std;
struct uuu
{
    int a[2][2];
    void init() //初始化
    {
        a[0][0]=0;
        a[0][1]=a[1][0]=a[1][1]=1;
    }
};
uuu lsz(uuu a,uuu b)
{
    uuu c;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<=1;j++)
        {
            c.a[i][j]=0;
            for(int k=0;k<2;k++)
            {
                c.a[i][j]=(c.a[i][j]+a.a[i][k]*b.a[k][j])%10000; 
            }
        }
    }
    return c;
}
uuu lll(uuu s,int k)
{
    uuu ans;
    ans.init();
    while(k>=1)
    {
        if(k&1)
            ans=lsz(ans,s);
        k>>=1;
        s=lsz(s,s);
    }
    return ans;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)break;
        if(n==0)
        {
            printf("0\n");
            continue ;
        }
        uuu s;
        s.init();
        s=lll(s,n-1);
        printf("%d\n",s.a[0][1]%10000);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值