UVA11059 - Maximum Product

Maximum Product
Time limit: 3.000 seconds
Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of themaximum positive product involving consecutive terms of S. If you cannot find a positive sequence,you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Siisan integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of eachelement in the sequence. There is a blank line after each test case. The input is terminated by end offile (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, whereM is the number of the test case, starting from 1, and P is the value of the maximum product. Aftereach test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.




题意是在n个元素组成的序列S中,找一个乘积最大的连续子序列。一个枚举的水题,直接枚举起点和终点即可!(需注意乘积为负数时输出0)


#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

const int Max = 20;
const int INF = 1000000000;
int a[Max], n;

int main()
{
    int temp = 0;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));
        for(int i = 0; i < n; i++)
            scanf("%d",&a[i]);
        long long sum, ans = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = i; j < n; j++)
            {
                sum = 1;
                for(int k = i; k <= j; k++)
                    sum *= a[k];
                ans = max(ans,sum);
            }
        }
        printf("Case #%d: The maximum product is %lld.\n\n",++temp,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值