hdu1024 Max Sum Plus Plus--DP

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1024


一:原题内容

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 
Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 
Output
Output the maximal summation described above in one line.
 
Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 
Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

二:分析理解

最大m段子序列和问题。

设输入的数组为a[1...n],从中找出m个段,使者几个段的和为最大

dp[i][j]表示前j个数中取i个段的和的最大值,其中最后一个段包含a[j]。(这很关键)

则状态转移方程为:

dp[i][j]=max{dp[i][j-1]+a[j],max{dp[i-1][t]}+a[j]}    i-1=<t<=j-1

因为dp[i][j]中a[j]可能就自身一个数组成最后一段,或者a[j]与a[j-1]等前面的数组成最后一段。

此题n数据太大,二维数组开不下,而且三重循环,想到状态转移方程后还是困难重重。

想想,二维数组不行的话,肯定要压缩成一维数组:

因为dp[i-1][t]的值只在计算dp[i][j]的时候用到,那么没有必要保存所有的dp[i][j] 1<=i<=m,这样我们可以用一维数组存储。

用pre[j]表示j之前一个状态dp[i-1][]中1---j之间,不一定包含a[j]的最大字段和,然后推dp[i][j]状态时,dp[i][j]=max{pre[j-1],dp[j-1]}+a[j];


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  

using namespace std;

int dp[1000010];
int pre[1000010];
int a[1000010];

int main()
{
	int m, n;
	int maxx;

	while (~scanf("%d%d", &m, &n))
	{
		for (int i = 1; i <= n; i++)
			scanf("%d", &a[i]);

		memset(pre, 0, sizeof(pre));

		for (int i = 1; i <= m; i++)
		{
			maxx = -1 << 28;

			for (int j = i; j <= n; j++)
			{
				dp[j] = max(dp[j - 1], pre[j - 1]) + a[j];
				pre[j - 1] = maxx;

				if (maxx < dp[j])
					maxx = dp[j];
			}
		}

		printf("%d\n", maxx);

	}

	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值