B - KiKi's K-Number HDU - 2852 (树状数组套二分)

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations. 

Push: Push a given element e to container 

Pop: Pop element of a given e from container 

Query: Given two elements a and k, query the kth larger number which greater than a in container; 

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem? 

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning , p which has three values: 
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container. 

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container   

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number. 

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5 
0 5 
1 2 
0 6 
2 3 2 
2 8 1 
7 
0 2 
0 2 
0 4 
2 1 1 
2 1 2 
2 1 3 
2 1 4

Sample Output

No Elment! 
6 
Not Find! 
2 
2 
4 
Not Find!

题意:容器就是支持这三个操作。 
推送:将给定元素e推送到容器 
Pop:来自容器的给定e的Pop元素 
查询:给定两个元素a和k,查询大于a的容器中的第k个大的数字;

思路:开一个100000大小的数组。sum[i]代表的是在该队列中0到i的数目大小。推送,以及pop相当于跟新这个树状数组add(i,1)或者add(i,-1)。查询也好写。题目问的是给定两个元素a和k,查询大于a的容器中的第k个更大的数字;那就是sum[I]-sum[i]==k,查找这个I的值。一开始想的话就是I大于i小于n,所以直接遍历的话是可以可以的,但是绝对会T。因为sum数组是非递减序列,所以对i到n进行二分操作找出I值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
using namespace std;
int C[100100];
int n=100100;
int lowbit(int i)
{
    return i&-i;
}
void updata(int i,int val)
{
    while(i<=n)
    {
        C[i]=C[i]+val;
        i=i+lowbit(i);
    }
}
int sum(int i)
{
    int ret=0;
    while(i>0)
    {
        ret =ret+C[i];
        i=i-lowbit(i);
    }
    return ret;
}
int get_sum(int l,int r,int u,int k)
{
    if(l==r&&sum(r)-sum(u)<k) return -1;
    if(l==r&&sum(r)-sum(u)>=k) return r;
    int mid=(l+r)/2;
    if(sum(mid)-sum(u)>=k)
        return get_sum(l,mid,u,k);
    else
        return get_sum(mid+1,r,u,k);
}
int main()
{
    int Q;
    while(scanf("%d",&Q)!=EOF)
    {
        memset(C,0,sizeof(C));
        int op;
        for(int i=0; i<Q; i++)
        {
            scanf("%d",&op);
            if(op==0)
            {
                int u;
                scanf("%d",&u);
                updata(u,1);
            }
            else if(op==1)
            {
                int u;
                scanf("%d",&u);
                if(sum(u)-sum(u-1)>0)
                    updata(u,-1);
                else
                    printf("No Elment!\n");
            }
            else
            {
                int u,k;
                scanf("%d %d",&u,&k);
                int temp=get_sum(u,n,u,k);
                if(temp==-1)
                    printf("Not Find!\n");
                else
                    printf("%d\n",temp);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值