KiKi's K-Number HDU - 2852 (树状数组+二分)

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations. 

Push: Push a given element e to container 

Pop: Pop element of a given e from container 

Query: Given two elements a and k, query the kth larger number which greater than a in container; 

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem? 

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values: 
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container. 

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container   

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number. 

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

题意:输入 0 ->向容器中加入元素a

                   1->删除元素a

                    如果容器中无元素a输出“No Elment!”

                   2->输出比a大的第k个元素

                   如果找不到输出“Not Find!”

思路:加入元素a或删除的时候对树状数组进行更新,这题的一个重点就是二分,不二分,一个一个查找的话会时间超限

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxx=100005;
#define lowbit(x) x&(-x)
int c[maxx];
void update(int x,int v)
{
    for(int i=x;i<=maxx;i+=lowbit(i))
        c[i]+=v;
}
int gestsum(int x)
{
    int num=0;
    for(int i=x;i;i-=lowbit(i))
        num+=c[i];
    return num;
}
int main()
{
    int n,s,add;
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
           scanf("%d",&s);
           if(s==0)
           {
               scanf("%d",&add);
               update(add,1);
           }
           else if(s==1)
           {
               scanf("%d",&add);
               if(gestsum(add)-gestsum(add-1)==0)
                printf("No Elment!\n");
               else
                update(add,-1);
           }
           else
           {
               int a,k;
               scanf("%d%d",&a,&k);
               if(gestsum(maxx)-gestsum(a)<k)
                printf("Not Find!\n");
               else
               {
                   int l=a+1,r=maxx,mid;
                   while(l<r)
                   {
                       mid=(l+r)/2;
                       if(gestsum(mid)-gestsum(a)<k)
                       {
                           l=mid+1;
                       }
                       else
                       {
                           r=mid;
                       }
                   }
                   printf("%d\n",r);
               }
           }
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值