C - Cow Exhibition POJ - 2184 01背包变换

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.  题意:一定数量的牛,主人带牛参加比赛,

然后接下来输入每头牛的智商和情商 ,要求最后选出来的牛智商+情商最大
然后智商和情商都不能为负
思路:
以智商作为容量,求前i头牛在智商为j的情况下的最大情商
因为有负数,所以容量扩大100000 dp[i][j]优化掉第i维
然后套01背包,
当s[i]<0的时候, 此时j - s[i] > j,所以j要顺着来,注意下顺序就行

代码:

#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
const int inf=0x3f3f3f3f;
int a[110],b[110];
int dp[220000];   //此处数组不可太小,如果小了,就会出错。
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;++i)
        {
            scanf("%d%d",&a[i],&b[i]);
        }
        memset(dp,-inf,sizeof(dp));
        dp[100000]=0;
        for(int i=1;i<=n;++i)
        {
            if(a[i]>=0)
            {
                for(int j=200000;j>=a[i];--j)
                {
                    if(dp[j-a[i]]!=-inf)
                    {
                        dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
                    }
                }
            }
            else
            {
                for(int j=0;j<=200000;j++)
                {
                    if(dp[j-a[i]]!=-inf)
                    {
                        dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
                    }
                }
            }
        }
        int maxx=0;
        for(int j=100001;j<=200000;j++)
        {
            if(dp[j]>0&&dp[j]!=-inf)
            {
                maxx=max(maxx,dp[j]+j-100000);
            }
        }
        cout<<maxx<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值