Number Sequence(HDU-1005)

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5
这道题其实是有规律的,f(n)对7求余一共有7种情况,俩之和对7求余所以共有49种情况,如果直接递归来算的话就会出现内存超限的问题,因此在计算之后会发现有规律,a,b,各有7种情况。

#include<stdio.h>
int a,b;
long long f(int n)
{
	if(n==1||n==2)
		return 1;
	return ((a%7)*f(n-1)+(b%7)*f(n-2))%7;
}
int main()
{
	int n;
	while(scanf("%d%d%d",&a,&b,&n),a!=0||b!=0||n!=0)
	{
		printf("%lld\n",f(n%49));
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值