HDU1241-Oil Deposits(dfs染色)

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output
0
1
2
2
解题思路:本题任然是dfs染色的应用,原本的模型是有一片海洋,给出这片海洋的的二维数组,问这篇海域有几个岛,用的方法就是染色,就是给不同的岛屿染成不同的颜色,最后看有几种颜色就有几个岛,这道题因为都是字符,因此不好进行染色,但是可以用染色的思想来写。
AC代码如下:

#include<stdio.h>
#include<string.h>
int n,m;
char map[200][200];
void dfs(int x,int y)
{
	int i,tx,ty;
	int next[8][2]={{0,1},{1,0},{0,-1},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
	map[x][y]='*';//这个点用过之后就给它变成是无油的,相当于染色的过程
	for(i=0;i<8;i++)
	{
		tx=x+next[i][0];
		ty=y+next[i][1];
		if(tx<0||ty<0||tx>n-1||ty>m-1)
			continue;
		if(map[tx][ty]=='@')
			dfs(tx,ty);
	}
	return ;
}
int main()
{
	int i,j,sum;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0||m==0)
			break;
		sum=0;
		/*for(i=0;i<n;i++)
		{
			getchar();
			for(j=0;j<m;j++)
				scanf("%c",&map[i][j]);
		}*/
		//上面这种输入对于本题来说有问题,因为仔细看了之后你会发现,在复制粘贴样例的时候每一行后面还有一个空格
		for(i=0;i<n;i++)
			scanf("%s",&map[i]);
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')//每次找到油田后就把与它相邻的八个方向的油田都给找出来
				{
					sum++;
					dfs(i,j);
				}
			} 
		}
		printf("%d\n",sum);
	}
	return 0;
} 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值