Arctic Network(最小生成数prime)

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意描述:这道题的意思就是有几个前哨兵,现象让它们之间都能相互(直接或者)联系,如果有卫星信道的两个前哨之间可以不管位置如何都能相互联系,否则的话,二者之间的距离就不能超过D,现在给你每个前哨的位置,问D至少需要多少。

解题思路:这道题很容易想到思路,就是用dis先把每个点之间的距离求出来,然对dis数组进行从小到大的排序,讲卫星信道给距离最大的那几个,最后输出dis[m-n+1]即可,不过我下面写的数组都是从0开始的,因此我输出的是dis[m-n],至于为什么读懂题之后你就明白了。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
	int x;
	int y;	
}que[20000];
//一开始我的这个函数本来写的是完整distance这个单词,但是他与algorithm这个头文件冲突,最后只能将这个单词写的不完整
double distanc(int a,int b)
{
	double t1,t2;
	t1=que[b].x-que[a].x;
	t2=que[b].y-que[a].y;
	return sqrt(t1*t1+t2*t2);
}
double e[2000][2000],dis[20000];
int book[20000];
int inf=999999999;
int main()
{
	int count,i,j,k,n,m,t,max,min;
	double t1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		count=0;
		for(i=0;i<m;i++)
			scanf("%d%d",&que[i].x,&que[i].y);
		memset(book,0,sizeof(book));
		for(i=0;i<m;i++)
		{
			for(j=0;j<m;j++)
			{
				e[i][j]=distanc(i,j);
				e[j][i]=e[i][j];
			}	
		}	
		for(i=0;i<m;i++)
			dis[i]=e[0][i];
		book[0]=1;
		count++;
		while(count<m)
		{
			min=inf;
			for(i=0;i<m;i++)
			{
				if(book[i]==0&&dis[i]<min)
				{
					min=dis[i];
					j=i;
				}
			}
			book[j]=1;
			count++;
			for(k=0;k<m;k++)
				if(book[k]==0&&dis[k]>e[j][k])
					dis[k]=e[j][k];
		}
		sort(dis,dis+m);
		printf("%.2f\n",dis[m-n]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值