POJ3262 Protecting the Flowers - 贪心法

Protecting the Flowers

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11508   Accepted: 4671

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N
Lines 2…N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics
Output

Line 1: A single integer that is the minimum number of destroyed flowers
Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Hint

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.

 
 

 
 

分析:

首先根据题意,一头牛的时间可以等效为 2 T 2T 2T ,接下来可以想一想几何意义,把第 i i i 头牛想象成一个底为 2 T i 2T_i 2Ti ,高为 D i D_i Di 的矩形,总的花费应该是一系列高度不断下降的矩形在 x ≥ 0 , y ≥ 0 x≥0,y≥0 x0,y0 部分的积分面积,其中 x x x 轴代表时间, y y y 轴代表单位时间的花费。那么我们只需要构造积分面积最小的凹函数即可,只需让对角线斜率的绝对值大的矩形排在前面就可以了,也就是按照 D i 2 T i \frac{D_i}{2T_i} 2TiDi 从大到小排序即可。

 
 

下面贴代码:

#include <cstdio>
#include <algorithm>
using namespace std;

typedef long long ll;
const int MAX_N = 100005;

struct Cow
{
	int T;
	int D;
	double x;
	bool operator< (const Cow& _Right)const
	{
		return x > _Right.x;
	}
}cows[MAX_N];

int main()
{
	int N;
	scanf("%d", &N);

	for (int i = 0; i < N; ++i)
	{
		Cow& cur = cows[i];
		scanf("%d%d", &cur.T, &cur.D);
		cur.T <<= 1;
		cur.x = (double)cur.D / cur.T;
	}
	sort(cows, cows + N);

	ll ans = 0, t = 0;
	for (int i = 0; i < N; ++i)
	{
		const Cow& cur = cows[i];
		ans += cur.D * t;
		t += cur.T;
	}
	printf("%lld\n", ans);

	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值