PAT甲级——1124 Raffle for Weibo Followers (set或者unordered_set的应用)

1124 Raffle for Weibo Followers (20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

题目大意:在转发转发微博的人(一堆名字)中按照设定好的规则选择中奖者;M是转发的人数,N是选择winner时间隔的人数,S是第一个winner的index。。。

思路:把名字依次放入字符串数组name中,遍历name,若当前的转发者不在集合se中,则为winner,输出人名并且将它放入se中;若当前的转发者在se中,则往后找name;遍历name之后如果se为空,则输出“Keep going...”

#include <iostream>
#include <string>
#include <vector>
#include <unordered_set>
using namespace std;

int main()
{
	int M, N, S;
	scanf("%d%d%d", &M, &N, &S);
	unordered_set<string> se;
	vector<string> name;
	for (int i = 0; i < M; i++) {
		string tmp;
		cin >> tmp;
		name.push_back(tmp);
	}
	for (int i = S-1; i < name.size(); i = i + N) {
		while (1) {
			if (i >= name.size())
				break;
			if (se.find(name[i]) == se.end())
				break;
			i++;
		}
		if (i < name.size()) {
			cout << name[i] << endl;
			se.insert(name[i]);
		}
	}
	if (se.empty())
		printf("Keep going...\n");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值