田忌赛马(贪心)

题目描述 

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0

解题思路 

刚开始是按照这样的思路写的:

每次都用田忌最快的马与齐王第二快的马比较,田忌最慢的马与齐王最快的马比较。这样会出现一个问题,用一个样例理解一下:

3

99 99 2

99 98 1

当田忌最快的马与齐王最快的马速度相等时,按照上面的方法,最后赢得200。然而若是一对一的比较的话,可以赢得400。所以这样的做法是有问题的。

正确的思路:

当田忌最快的马比齐王最快的马快,胜利的次数加1。

否则,当田忌最慢的马比齐王最慢的马快,胜利的次数加1。

否则,用田忌最慢的马与齐王最快的马比较,实现田忌的策略,有两种情况,失败次数加1,或者平局不计入次数,不可能出现田忌最慢的马比齐王最快的马还快,因为前面已经事先将田忌最快的马与齐王最快的马比较,田忌最快的马都比它慢,不可能之后的马比它快。

这样的话,可以胜利的最多。

代码

 

#include<stdio.h>
#include<algorithm>
using namespace std;

bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int n,i,tjfast,tjslow,kingfast,kingslow,win,lose;
	int a[1005],b[1005],sum;
	while(scanf("%d",&n)==1&&n!=0)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&b[i]);
		}
		sort(a,a+n,cmp);  //从大到小排序 
		sort(b,b+n,cmp);
		tjfast=0,tjslow=n-1;kingfast=0,kingslow=n-1;
		win=0,lose=0;
		for(i=0;i<n;i++)     //进行n轮比较 
		{
			if(a[tjfast]>b[kingfast])   //最快的比较 
			{
				win++;
				tjfast++;
				kingfast++;
			}
			else if(a[tjslow]>b[kingslow])  //最慢的比较 
			{
				win++;
				tjslow--;
				kingslow--;
			}
			else
			{
				if(a[tjslow]<b[kingfast])   //田忌最慢的马与齐王最快的马比较 
				{
					lose++;
					tjslow--;
					kingfast++;
				}
			}
		}
		sum=(win-lose)*200;
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 4
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值