计算几何:Intersecting Lines(不优雅)

001:Intersecting Lines
查看提交统计提问
总时间限制: 1000ms 内存限制: 65536kB
描述
We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.
输入
The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).
输出
There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read “END OF OUTPUT”.
样例输入
5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5
样例输出
INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT
来源
Mid-Atlantic 1996

#include <cmath>
#include <iostream>
#include <string>
#include <iomanip>
using namespace std;
struct CVector
{
    double x;
    double y;
    CVector() {}
    CVector(double xx, double yy)
    {
        x = xx;
        y = yy;
    }
};
struct CPoint
{
    double x;
    double y;
    CPoint() {}
    CPoint(double xx, double yy)
    {
        x = xx;
        y = yy;
    }
    void init(double xx, double yy)
    {
        x = xx;
        y = yy;
    }
};
struct CLine
{
    CPoint a;
    CPoint b;
    CLine() {}
    void init(CPoint xx, CPoint yy)
    {
        a = xx;
        b = yy;
    }
};
CLine p, q;
CVector operator-(CPoint b, CPoint a) { return CVector(b.x - a.x, b.y - a.y); } // c = a – b;
CVector operator *(double k, CVector p) { return CVector(k * p.x, k * p.y);}
double operator ^(CVector p, CVector q) { return p.x * q.y - q.x * p.y;}
double area(CVector p, CVector q) { return (p^q) / 2;}
double PI = acos(-1); double INF = 1e20; double EPS = 1e-6; //精度不是越高越好
bool IsZero(double x) { return -EPS < x && x < EPS;}
double operator *(CVector p, CVector q) { return p.x * q.x + p.y * q.y;}
double length(CVector p) { return sqrt(p * p);} 
double dist(CPoint p, CPoint q) { return length(p - q);}
CPoint operator +(CPoint a, CVector p) { return CPoint(a.x + p.x, a.y + p.y); } 
double dist(CPoint p, CLine l) { return fabs((p - l.a) ^ (l.b - l.a)) / length(l.b - l.a);}
CPoint intersect(CLine l, CLine m)
{
    double x = area(m.a - l.a, l.b - l.a);
    double y = area(l.b - l.a, m.b - l.a);
    if (IsZero(x + y))
    {
        CPoint ss(1001, -1001);
        if (IsZero(dist(l.a, m)))
        {
            ss.y -= 1;
            return ss;
        }
        else
        {
            return ss;
        }
            
    }
    return m.a + ((x / (x + y)) * (m.b - m.a));
}
int main()
{
  /*  freopen("i", "r", stdin);
    freopen("o", "w", stdout);*/
    int cases;
    cin >> cases;
    cout << "INTERSECTING LINES OUTPUT" << endl;
    while (cases--)
    {
        CPoint a, b;
        double x1, y1, x2, y2;
        for (double i = 0; i < 2; i++)
        {
            cin >> x1 >> y1 >> x2 >> y2;
            a.init(x1, y1);
            b.init(x2, y2);
            if (i == 0)
                p.init(a, b);
            else
                q.init(a, b);
        }
        CPoint mm = intersect(p, q);
        if(fabs(mm.y + 1001) <= 1e-6)
        {
            cout << "NONE" << endl;
        }
        else if(fabs(mm.y + 1002) <= 1e-6)
        {
            cout << "LINE" << endl;
        }
        else 
        {
            cout << "POINT " << fixed << setprecision(2) << mm.x  << " " << setprecision(2) << mm.y << endl;
        }
    }
    cout << "END OF OUTPUT" << endl;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值