PTA关键点1065 A+B and C (64bit)

https://pintia.cn/problem-sets/994805342720868352/problems/994805406352654336

https://blog.csdn.net/liuchuo/article/details/52109211?ops_request_misc=%257B%2522request%255Fid%2522%253A%2522163646030416780255222993%2522%252C%2522scm%2522%253A%252220140713.130102334.pc%255Fblog.%2522%257D&request_id=163646030416780255222993&biz_id=0&utm_medium=distribute.pc_search_result.none-task-blog-2blogfirst_rank_v2~rank_v29-2-52109211.pc_v2_rank_blog_default&utm_term=1065&spm=1018.2226.3001.4450

1065 A+B and C (64bit) (20)
Given three integers A, B and C in (2 
63
 ,2 
63
 ), you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
结尾无空行
Sample Output:
Case #1: false
Case #2: true
Case #3: false
结尾无空行

1、根据溢出判断大小
long long是8个字节,在有符号数时取值范围为-263 ~263 -1,所以可以保存题目中的数字。
问题在于当两个数字都大于0或小于0时相加可能会发生溢出,溢出后的结果就不是原有结果了

以两个数为正数为例,假如都取最大值232 - 1,那么相加后的结果就是264 - 2,由于溢出,当记录到263 时,溢出后数值为10000.。。。00(63个0),即-263 (因为0有两种表示方法,正0和负0,因此计算机中将负0的这种状态记录为-263 ,因为64位中最前面的一位作为符号位,所以63位表示数值),因此当263 时,计算机表示为-263 ,263 到264 - 2 之间还有263 - 2个数,因此计算机中表示值继续向前平移263 -2个数最终得到-2,因此两个正数相加溢出时的取值范围为-263~ -2

两个数为负数时,两个-263 相加为-264 ,当-263 - 1时,计算机表示为0,因此当原值为-264时,计算机表示为263 - 1,溢出值取值范围为0~263 - 1

2、scanf("%lld%lld%lld",&A,&B,&C);
这一句替换为cin >> A >> B >> C第三个样例会发生错误,暂时不知道是什么原因,我尝试手动输入溢出的样例,cin都是能通过的,因为看不到提供的样例,所以不知道什么问题

只能提醒自己实在不行时试着将cin改为scanf


#include <cstdio>
#include <cstdlib>
#include <iostream>
using namespace std;

int main(){
    int n = 0;
    cin >> n;
    for(int i = 1;i <= n;++i){
        long long A,B,C;
        scanf("%lld%lld%lld",&A,&B,&C);
        long long sum = A + B;
        if(A > 0&&B > 0&&sum < 0){
            printf("Case #%d: true\n",i);
        }
        else if(A < 0&&B < 0&&sum >= 0){
            printf("Case #%d: false\n",i);
        }
        else if(sum > C){
            printf("Case #%d: true\n",i);
        }
        else{
            printf("Case #%d: false\n",i);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值