PAT甲级1138 Postorder Traversal先序中序输出后序

1138

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:
7
1 2 3 4 5 6 7
2 3 1 5 4 7 6
结尾无空行
Sample Output:
3
结尾无空行

题目

先序中序输出后序

节点多达50000个,如果完整的构建二叉树再进行后序遍历的话后两个测试点会超时

所以不用构建二叉树,直接按照后序遍历的顺序进行。根据中序和先序找到根节点以及左右子树,找到左子树下最左边节点(如果没有那就是左子树中最右边节点)即后序遍历的第一个节点,然后输出。(这里的flag不能省略,在输出过后就无需进行遍历,否则会超时)

#include <iostream>
#include <vector>
using namespace std;
vector<int> pre;
vector<int> in;
int n;
int flag = 0;
void postorder(int root,int start,int end){
    if(start > end||flag == 1){
        return;
    }
    int i = start;
    for(;i <= end;++i){
        if(pre[root] == in[i]){
            break;
        }
    }
    if(i != start){
        postorder(root + 1,start,i - 1);
    }
    if(i != end){
        postorder(i - start + root + 1,i + 1,end);
    }
    if(flag == 0){
        cout << in[i];
        flag = 1;
    }
    return;
}
int main(){
    cin >> n;
    pre.resize(n);
    in.resize(n);
    for(int i = 0;i < n;++i){
        cin >> pre[i];
    }
    for(int i = 0;i < n;++i){
        cin >> in[i];
    }
    postorder(0,0,n - 1);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值