蓝桥杯练习——入门训练2

题目三:

问题描述
求1+2+3+…+n的值。
输入格式:输入包括一个整数n。
输出格式:输出一行,包括一个整数,表示1+2+3+…+n的值。
样例输入:4
样例输出:10

方法一:
这个是很容易想到的求数列和的方法,就是用 for 循环。但是这种运算在当求很大数数列和时会导致运行超时以及数值溢出的现象。

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {
	int i, t=0, m=0;
	
	scanf("%d",&m);
	for(i = 1; i <= m; i++){
		t += i;
	}
	printf("%d",t);
	return 0;
}

方法二:

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {
	int m=0;
	int t=0;
	
	scanf("%d",&m);
	t = ((m+1)*m)/2;			//数列求和公式嘛
	printf("%d",t);
	
	return 0;
}

最简单的方法就是;

#include <stdio.h>
#include <stdlib.h>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char *argv[]) {
	long long m=0, t=0;			//足够空间
	
	scanf("%d",&m);
	t = ((m+1)*m)/2;
	printf("%lld",t);
	
	return 0;
}

论——初始化的重要性
非常非常的重要!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值