POJ -2318 TOYS(差积判断点与直线位置)

TOYS

Time Limit: 2000MSMemory Limit: 65536K

Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
在这里插入图片描述
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint
As the example illustrates, toys that fall on the boundary of the box are “in” the box.

将给的n条边和矩形右边界共n+1条边0…n编号,利用差积公式判断点和每条边的位置即可。

现在有两点A(ux,uy),B(dx,dy)组成一条直线,要判断T(tx,ty)与直线的位置关系,设向量AT(tx-ux,ty-uy)、向量AB(dx-ux,dy-uy),如果AB*AT<0,说明向量AT在向量AB右边(站在A点面朝B点),反之在左边。

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <vector>
#include <stack>
using namespace std;
#define inf 0x3f
#define N 50005

struct point
{
    int x, y;
};
struct Side
{
    point up, down;
};
Side side[N];

int cnt[N];

int main()
{
    int n, m, x1, y1, x2, y2;
    while(scanf("%d", &n),n)
    {
        scanf("%d%d%d%d%d", &m, &x1, &y1, &x2, &y2);
        side[n].up.x = side[n].down.x = x2;
        side[n].up.y = y1, side[n].down.y = y2;//y坐标可以省略,要么y1要么y2
        int ux, dx, uy, dy;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d", &ux, &dx);
            side[i].up.x = ux, side[i].up.y = y1;
            side[i].down.x = dx, side[i].down.y = y2;
        }
        memset(cnt, 0, sizeof cnt);
        int tx, ty;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d", &tx, &ty);
            for(int j=0; j<=n; j++)
            {
                ux = side[j].up.x, uy = side[j].up.y;
                dx = side[j].down.x, dy = side[j].down.y;
                if((dx-ux)*(ty-uy)-(dy-uy)*(tx-ux)<0)//
                {
                    cnt[j]++;
                    break;
                }
            }
        }
        for(int i=0; i<=n; i++)
            printf("%d: %d\n", i, cnt[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值