POJ -2566 Bound Found(尺取法,前缀和)

Bound Found

Time Limit: 5000MSMemory Limit: 65536K

Description
Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input
5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output
5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

题意:元素个数n,询问次数k,然后给n个数,k个询问,每个询问一个数字x,从n个数中,找一个连续子序列,区间和的绝对值最接近x,输出这个绝对值和区间左右下标。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

struct date
{
    int id, sum;//编号id和[0,id]区间和sum
}c[100004];

int cmp(date a, date b)
{
    return a.sum<b.sum;
}

int main()
{
    int n, k;
    while(scanf("%d%d", &n, &k))
    {
        if(n==k&&!n)
            break;
        c[0].id=0, c[0].sum=0;
        for(int i=1; i<=n; i++)//从1开始
        {
            scanf("%d", &c[i].sum);
            c[i].sum+=c[i-1].sum;
            c[i].id=i;
        }
        sort(c, c+n+1, cmp);//升序排序
        while(k--)
        {
            int t;
            scanf("%d", &t);
            int l=0, r=1, ans, ansl, ansr, abmin=1e10;
            while(r<=n)
            {
                int s=c[r].sum-c[l].sum;
                if(abs(s-t)<abmin)//abs()越小越接近
                {
                    abmin=abs(s-t);//更新最近距离
                    ans=s;
                    ansl=c[l].id;
                    ansr=c[r].id;
                }
                if(s<t)//如果s太小,r右移,使被减数c[r].sum更大
                    r++;
                else//如果s太大,l右移,使减数c[l].sum更大
                    l++;
                if(l==r)
                    r++;
            }
            printf("%d %d %d\n", ans, min(ansl, ansr)+1, max(ansl, ansr));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值