POJ -2549 Sumsets(二分,枚举)

Sumsets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13364 Accepted: 3668
Description

Given S, a set of integers, find the largest d such that a + b + c = d where a, b, c, and d are distinct elements of S.
Input

Several S, each consisting of a line containing an integer 1 <= n <= 1000 indicating the number of elements in S, followed by the elements of S, one per line. Each element of S is a distinct integer between -536870912 and +536870911 inclusive. The last line of input contains 0.
Output

For each S, a single line containing d, or a single line containing “no solution”.
Sample Input

5
2
3
5
7
12
5
2
16
64
256
1024
0
Sample Output

12
no solution

将a+b+c=d转换为a+b=d-c
j为什么从’n-1’开始而不是’i-1’,因为有负数的存在,数组最右边的不一定是最大的d,比如"-1 -2 7 10"这组数据,c取10,最大的d才是7,如果’j=i-1’,那么c不可能去到j右边的,会出错。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

int n, a[1005];

int main()
{
    while(scanf("%d", &n), n)
    {
        for(int i=0; i<n; i++)
            scanf("%d", &a[i]);
        sort(a, a+n);
        int flag=0, ans;
        for(int i=n-1; i>=0; i--)//模拟d
        {
            for(int j=n-1; j>=0; j--)//模拟c
            {
                if(a[i]==a[j])
                    continue;
                long long sum=a[i]-a[j];
                int l=0, r=j-1;
                while(l<r)
                {
                    long long s=a[l]+a[r];
                    if(sum==s)//此时a+b=c-d
                    {
                        flag=1;
                        ans=i;
                        break;
                    }
                    else if(sum<s)//s太大,r左移
                        r--;
                    else
                        l++;
                }
                if(flag)
                    break;
            }
            if(flag)
                break;
        }
        if(flag)
            printf("%d\n", a[ans]);
        else
            printf("no solution\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值