HDU -1016 Prime Ring Problem(DFS)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意:n个数围成圆圈,要求相邻的数之和为素数,求有几种情况,输出这些情况。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string.h>
#include <queue>
#include <cmath>
using namespace std;

int vis[21], date[21];//标记数组和输出数组
//int dir[8][2]= {{1,0},{1,1},{1,-1},{0,1},{0,-1},{-1,0},{-1,1},{-1,-1}};
int n;

int isprime(int x)
{
    if(x==1)
        return 0;
    int t=sqrt(x);
    for(int i=2; i<=t; i++)
        if(x%i==0)
            return 0;
    return 1;
}

void dfs(int l)
{
    if(l==n)//此时n个数都用上了
    {
        if(isprime(date[n-1]+date[0])==0)//判断数组最后一个和第一个数之和
            return;
        for(int i=0; i<n-1; i++)
            printf("%d ",date[i]);
        printf("%d\n",date[n-1]);
        return;
    }
    for(int i=1; i<=n; i++)
    {
        if(vis[i]==1||isprime(date[l-1]+i)==0)
            continue;
        vis[i]=1;
        date[l]=i;
        dfs(l+1);
        vis[i]=0;
        date[l]=0;
    }
}

int main()
{
    int q=1;
    while(scanf("%d", &n)!=EOF)
    {
        memset(vis, 0, sizeof(vis));
        printf("Case %d:\n",q++);
        date[0]=1;
        vis[1]=1;
        dfs(1);
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值