HDU -1520 Anniversary party(树形DP)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output
Output should contain the maximal sum of guests’ ratings.

Sample Input
7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output
5

题意:先给一个数n,然后是n个人的欢乐度,再给出多行k,l,表示k是l的主管,但是每个人都不想跟他们的主管一起出现,现在求这个party的最大欢乐度。

dp[i][0]表示i不参加的最大值,dp[i][1]表示i参加的最大值。
假设i的主管是f,如果f不参加,那么i可以参加也可以不参加,如果f参加,那么i只能不参加,所以得到两个方程:
dp[f][0]+=max(dp[i][0], dp[i][1]);
dp[f][1]+=dp[i][0];

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;

int dp[6005][2], vis[6005];
int ba[6005], n;

void dfs(int f)
{
    vis[f]=1;
    for(int i=1; i<=n; i++)
    {
        if(ba[i]==f&&vis[i]==0)//如果i的主管是f
        {
            dfs(i);
            dp[f][0]+=max(dp[i][0], dp[i][1]);
            dp[f][1]+=dp[i][0];
        }
    }
}

int main()
{
    while(scanf("%d", &n)!=EOF)
    {
        memset(dp, 0, sizeof(dp));
        memset(ba, 0, sizeof(ba));
        memset(vis, 0, sizeof(vis));
        for(int i=1; i<=n; i++)
            scanf("%d", &dp[i][1]);
        int l, k;

        int flag=1, fpoint=1;
        while(scanf("%d%d", &l, &k), l||k)
        {
            ba[l]=k;
        }
        while(ba[fpoint])//求根节点,也就是没有主管管他的那个人
            fpoint=ba[fpoint];
        dfs(fpoint);
        int maxx=max(dp[fpoint][0], dp[fpoint][1]);
        printf("%d\n", maxx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值