A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
题意描述:
一个以1开头的一个素数环条件是每两个相邻的两个数之和为素数;
解题思路:
用到了回溯的方法,实际上还是深搜尝试不同位置放置不同的数,在每一次尝试后取消标记,满足条件加1输出最终结果即可
Accept Code:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int vis[21];
int s[21],n;
int is_prime(int x)
{
for(int i=2; i*i<=x; i++)
if(x%i==0) return 0;
return 1;
}
void dfs(int cur)
{
if(cur>n&&is_prime(s[n]+s[1]))
{
for(int i=1; i<n; i++)
printf("%d ", s[i]);
printf("%d\n", s[n]);
return ;
}
else for(int i=2; i<=n; i++)
{
if(vis[i]==0&&is_prime(s[cur-1]+i))
{
vis[i]=1;
s[cur]=i;
dfs(cur+1);
vis[i]=0;
}
}
}
int main()
{
int i,j,a=0;
while(scanf("%d", &n)==1)
{
memset(vis,0,sizeof(vis));
memset(s,0,sizeof(s));
printf("Case %d:\n", ++a);
s[1]=1; vis[1]=1;
dfs(2);
printf("\n");
}
return 0;
}