HDU1016Prime Ring Problem(深搜)

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
在这里插入图片描述
Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
题意描述:
一个以1开头的一个素数环条件是每两个相邻的两个数之和为素数;
解题思路:
用到了回溯的方法,实际上还是深搜尝试不同位置放置不同的数,在每一次尝试后取消标记,满足条件加1输出最终结果即可
Accept Code:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int vis[21];
int s[21],n;
int is_prime(int x)
{
	for(int i=2; i*i<=x; i++)
	 if(x%i==0) return 0;
	return 1;
}
void dfs(int cur)
{
	if(cur>n&&is_prime(s[n]+s[1]))
	{
		for(int i=1; i<n; i++)
		printf("%d ", s[i]);
		printf("%d\n", s[n]);
		return ; 
	}
	else for(int i=2; i<=n; i++)
	{
		if(vis[i]==0&&is_prime(s[cur-1]+i))
		{
			vis[i]=1;
			s[cur]=i;
			dfs(cur+1);
			vis[i]=0;
		}
	}
}
int main()
{
	int i,j,a=0;
	while(scanf("%d", &n)==1)
	{
		memset(vis,0,sizeof(vis));
		memset(s,0,sizeof(s));
		printf("Case %d:\n", ++a);
		s[1]=1; vis[1]=1;
		dfs(2);
		printf("\n");
	}
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值