POJ 1308 Is It A Tree? 并查集入门

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output
For each test case display the line Case k is a tree." or the lineCase k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

WA了好多遍,明白了什么是树

1: 0 0 空树是一棵树
2: 1 1 0 0 不是树 不能自己指向自己
3: 1 2 1 2 0 0 不是树…自己开始一直在这么WA 好郁闷 重复都不行呀~~5555
4: 1 2 2 3 4 5 不是树 森林不算是树(主要是注意自己)
5: 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 1 注意 一个节点在指向自己的父亲或祖先 都是错误的 即 9–>1 错
6: 1 2 2 1 0 0 也是错误的

代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define inf 100010
using namespace std;
int par[inf];
int root[inf];
int maxx,flag;
void init(){
    for(int i=1;i<inf;i++){
        par[i]=i;
        root[i]=0;
    }
    flag=1;maxx=0;
}
int fi(int x){
    if(par[x]==x)return x;
    return par[x]=fi(par[x]);
}
void un(int x,int y){
    if(x==y){
        flag=0;return ;//自己不能指向自己
    }
    int xx=fi(x);
    int yy=fi(y);
    if(xx==yy||y!=yy){//一个子节点只能有一个父亲
        flag=0;return ;
    }
    par[y]=x;//子节点链到父节点上 
}
int main(){
    int a,b,t=0;
    while(1){
        scanf("%d %d",&a,&b);
        if(a<0)break;
        init();
        while(1){
            if(a==0)break;
            if(flag){
                maxx=max(maxx,max(a,b));
                un(a,b);
            }
            scanf("%d %d",&a,&b);
        }
        t++;
        if(flag){
            int ans=0;
            for(int i=1;i<=maxx;i++){
                if(fi(i)!=i)root[fi(i)]++;
            }
            for(int i=1;i<=maxx;i++){
                if(root[i]>0)ans++;
            }
            if(ans>1)printf("Case %d is not a tree.\n",t);
            else printf("Case %d is a tree.\n",t);
        }else printf("Case %d is not a tree.\n",t);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值