HDU 1595 (枚举+最短路,Dijkstra)

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input
5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output
11
13
27

题意:求删掉任意一条边的最长最短路
思路:首先求出最短路,同时记录下路径,接着枚举最短路上
每一条边(将此边切段),在求最短路,求这些最短路中的最长路

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <queue>
using namespace std;
const int inf = 0x3f3f3f3f;
const int MAX = 1005;
const int MAXE = 5*1e5;

int mp[MAX][MAX];
int dis[MAX];
bool use[MAX];
int pre[MAX];
int ans, n;
void Dijkstra(int s,int e,bool flag)
{
    typedef pair<int, int > pii;
    priority_queue< pii, vector<pii>, greater<pii> > q;
    fill(dis, dis+n+1, inf);
    dis[s] = 0;
    if(flag) pre[s] = -1;
    q.push(make_pair(dis[s],s));
    while(!q.empty())
    {
        pii tmp = q.top();
        q.pop();
        int u = tmp.second;
        if(tmp.first != dis[u]) continue;
        for(int v = 1; v <= n; v ++)
        {
            if(mp[u][v] && dis[v] > dis[u] + mp[u][v])
            {
                dis[v] = dis[u] + mp[u][v];
                if(flag) pre[v] = u;
                q.push(make_pair(dis[v],v));
            }
        }
    }
    if(flag) return;
    if(dis[e] < inf)
        ans = max(ans, dis[e]);
}
void solve()
{
    int e = n;
    while(pre[e] != -1)//枚举每条边
    {
        int tmp = mp[e][pre[e]];
        mp[e][pre[e]] = mp[pre[e]][e] = 0;//将两边关系切断
        Dijkstra(1, n, false);
        mp[e][pre[e]] = mp[pre[e]][e] = tmp;
        e = pre[e];
    }
    printf("%d\n",ans);
}
int main()
{
    int m;
    while(~scanf("%d%d",&n,&m))
    {
        int u, v, c;
        memset(mp, 0, sizeof(mp));
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&c);
            mp[u][v] = mp[v][u] = c;
        }
        ans = 0;
        Dijkstra(1, n, true);
        solve();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值