PAT甲级A1065 A+B and C (64bit)

PAT甲级A1065 A+B and C (64bit)

题目:

Given three integers A, B and C in [−2^​63,2 ^​63​​], you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

Note:

超级大水题,除了需要注意一下正负溢出的情况没有任何难点

AC代码:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
	int k;
	ll a,b,c,res;
	cin>>k;
	for(int i=1;i<=k;i++)
	{
		cin>>a>>b>>c;
		res=a+b;
		printf("Case #%d: ",i);
		if(a>0&&b>0&&res<0) printf("true\n");
		else if(a<0&&b<0&&res>=0) printf("false\n");
		else if(res>c) printf("true\n");
		else printf("false\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值