While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith’s telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:
4937775= 355*65837
The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!
Input
The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.
Output
For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.
Sample Input
4937774
0
Sample Output
4937775
解题思路
题意就是给你一个数,找到比这个数大的最小的史密斯数字,史密斯数就是一个数的每个数字之和等于它的质因子的每个数字之和,题目明确指出质数不算史密斯数。
#pragma GCC optimize(2)
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
using namespace std;
const int maxn=1e7+10;
typedef long long ll;
map<int,int> mp;
//int a[maxn+10],prime[maxn+10];
//void fun()
//{
// prime[1]=prime[0]=1;
// for(int i=2;i*i<maxn;i++)
// {
// if(!prime[i])
// for(int j=i*i;j<maxn;j+=i)
// prime[j]=1;
// }
//} //用这方法打表内存会不够
int check(int x)
{
// int i=2;
// while(x>i&&(x%i)!=0) i++;
// if(x==i) return 1;
// else return 0; //用这个方法求会超时
for(int i=2;i*i<=x;i++)
{
if(x%i==0)
return 0;
}
return 1; //这个是最快的,
}
int digits(int x)
{
int sum=0;
while(x)
{
sum+=x%10;
x/=10;
}
return sum;//求各个位数之和
}
int sums(int n)
{
int sum=0;
int i=2;
while(1)
{
if(n%i==0)
{
sum+=digits(i);
if(check(n/=i))
{
break;
}
}
else i++;
}
return sum+=digits(n);//质因数之和
}
int main()
{
ios::sync_with_stdio(false);
int n;
// fun();
while(cin>>n&&n)
{
while(n++)
{
if(check(n)==0)
{
if(digits(n)==sums(n))
{
cout<<n<<endl;
break;
}
}
}
}
return 0;
}