PAT甲级1130

11 篇文章 1 订阅
10 篇文章 0 订阅

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题意:给出一棵表达式树,现在让你输出这颗树的前序遍历结果。
思路:由给出的边信息直接建树,完了跑一边dfs,难点是处理括号,我们发现对于每个节点,如果这个节点不是跟节点,并且这个节点不是叶子节点,那么每一次我们需要在访问这个节点之前输出“(”,在访问完这个节点之后我们输出“)”。这样这个题目就处理好了。

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 25
#define maxnode 1000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;

int n,root;
int Left[MAXN],Right[MAXN],in[MAXN];
char val[MAXN][100];

void dfs(int u)
{
    if(Left[u]!=-1&&u!=root||Right[u]!=-1&&u!=root)
        printf("(");
    if(Left[u]!=-1)
        dfs(Left[u]);
    printf("%s",val[u]);
    if(Right[u]!=-1)
        dfs(Right[u]);
   if(Left[u]!=-1&&u!=root||Right[u]!=-1&&u!=root)
        printf(")");
}

int main()
{
    memset(Left,-1,sizeof(Left));
    memset(Right,-1,sizeof(Right));
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%s",val[i]);
        scanf("%d %d",&Left[i],&Right[i]);
        if(Left[i]!=-1)
            in[Left[i]]++;
        if(Right[i]!=-1)
            in[Right[i]]++;
    }
    for(int i=1;i<=n;i++)
    {
        if(in[i]==0)
        {
            root=i;
            break;
        }
    }
    dfs(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值