1032 Sharing (25 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).
Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter
chosen from { a-z, A-Z }, and Next is the position of the next node.
Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.
Sample Input 1:`

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

题意:给你给出两个链表,输出第一个链表相交的节点。输入:第一行给出三个数字,分别是两个链表的头结点和节点个数。
思路:模拟一下,记录某个节点的访问的次数,输出第一个被访问两次的节点,如果某个没有一个节点访问两次,就直接输出-1.

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 100010
#define maxnode 2000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;

struct node
{
    char val;
    int nnext;
};
node P[MAXN];
int vis[MAXN];
int start_1,start_2,n;

void solve()
{
    while(start_1!=-1)
    {
        vis[start_1]++;
        start_1=P[start_1].nnext;
    }
    while(start_2!=-1)
    {
        vis[start_2]++;
        if(vis[start_2]==2)
        {
            printf("%05d\n",start_2);
            return ;
        }
        start_2=P[start_2].nnext;
    }
    printf("-1\n");
}

int main()
{
    scanf("%d %d %d",&start_1,&start_2,&n);
    for(int i=1;i<=n;i++)
    {
        int pos;
        scanf("%d",&pos);
        cin>>P[pos].val>>P[pos].nnext;
    }
    solve();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值