1119 Pre- and Post-order Traversals (30 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

题意:第一行给出一个正整数n。
下面两行分别给出一棵树的前序遍历和后序遍历。
要求确定这棵树的中序遍历是不是唯一的。如果是则输出“Yes”,
输出中序遍历序列不是则输出“No”。随意输出一个中序遍历
思路:关键在于如果某个父节点只有左孩子,或者只有右孩子,那么这个序列就
不是唯一的。因为两者的前序和后序遍历的结果是一样的。比如样例:
前序:1 2 3 4和后序遍历:2 4 3 1。那么我们可以发现根节点是1,左子树
为(2)(2)右子树为(3,4),(4,3)这个时候注意观察(3,4)和(4,3)前序的第一个等
与后续的最后一个,前序的第二个和后序的倒数第二个是一样的。这里就
是唯一的。也就是4可以左左子树,也可以做右子树。所以对于给出的序列
比如:1 2 3 4 6 7 5;2 6 7 4 5 3 1;前序遍历的第一个是1,后续遍历的
最后一个是1,前序遍历的第二个是2,后续遍历的倒数第二个是3,不一
样, 所以是左右子树都存在。这样不断判断下去。输出就好了。给出代码
吧:

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 50
#define maxnode 50010
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;

int n;
int pre_order[MAXN],post_order[MAXN];
bool Unique;
vector<int> inn;

void in_order(int pst,int ped,int post,int poed)
{
    if(pst==ped)
    {
        inn.push_back(post_order[poed]);
        return ;
    }
    int i=pst+1;
    while(pre_order[i]!=post_order[poed-1]&&i<=ped)     //在前序中找到后续的根节点(这样就可以确定出左子树的个数)
        i++;
    int left_child=i-pst-1;                                        //左子树的个数
    int right_child=ped-i+1;
    if(i==pst+1)
        Unique=false;                                                 //前序的第一个值等于后续的最后一个值,那么表明存在一个节点,只有一个左子树,或者只有一个右子树,就不唯一
    if(i-pst>1)
        in_order(pst+1,i-1,post,poed-right_child-1);   //简单推理一下,判断左子树的办法:pst+1==i-1=>i-pst==2,也就是i-pst>1
    inn.push_back(post_order[poed]);
    in_order(i,ped,poed-right_child,poed-1);
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&pre_order[i]);
    for(int i=1;i<=n;i++)
        scanf("%d",&post_order[i]);
    Unique=true;
    in_order(1,n,1,n);
    if(Unique)
        printf("Yes\n");
    else
        printf("No\n");
    for(int i=0;i<inn.size();i++)
        printf("%d%c",inn[i],i==inn.size()-1?'\n':' ');
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值