1119 Pre- and Post-order Traversals (30分) 前后序遍历写出中序遍历 树的遍历

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

 柳:前序的第一个点和后序的最后一个点相同,然后以后序最后一个点的前一个点作为分界,找到前序中此点的位置,在前序中位于此点之前根节点之后的所有即为左子树的点,此点(一定要包括此点)及之后的所有点即为右子树的点,然后递归。

#include <iostream>
#include <vector>

using namespace std;

vector<int> pre, post, in;
bool unique = true;

void getin(int preleft, int preright, int postleft, int postright)
{
	if (preleft==preright)
	{
		in.push_back(pre[preleft]);
		return;
	}
	if (pre[preleft]==post[postright])
	{
		int i = preleft+1;
		while (i<=preright&&pre[i]!=post[postright-1])
		{
			i++;
		}
		//处理顺序按照中序遍历的顺序,先左再中后右
		if (i-preleft>1)
		{//对左子树的点进行处理
			getin(preleft + 1, i - 1, postleft, postleft + (i - preleft - 1) - 1);
		}
		else
		{
			unique = false;
		}
		in.push_back(post[postright]);//把根(父)节点压进去
		//对右子树上的点进行处理
		getin(i, preright, postleft + (i - preleft - 1), postright - 1);
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	pre.resize(n + 1), post.resize(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> pre[i];
	}
	for (int i = 1; i <= n; i++)
	{
		cin >> post[i];
	}
	getin(1, n, 1, n);
	printf("%s\n%d", unique == true ? "Yes" : "No", in[0]);
	for (int i = 1; i < in.size(); i++)
	{
		cout << " " << in[i];
	}
	cout << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值