1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 题意分析:是一个家族树,对家族树进行遍历,找到叶子节点,并统计个层叶子节点的个数。我的思路是建立一个结构体,里面存储节点所在 的高度,节点的子节点个数,节点的子节点地址(用于遍历子节点)。由于题意为了方便直接把一号节点作为根节点,直接从根节点进行遍历,对每层叶子节点进行统计。所有节点我用数组进行存放,直接用位置也比较方便。

我记得有两个测试点是因为我输出接为没加\n,所以没过,但第二天没加还是过了,就很奇怪。

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
struct IDleave{//定义结构体,确定一个节点的编号,子节点个数,高度,子节点地址
    int high=1;//高度初始化
    int SonNum=0;//子节点个数初始化
    IDleave* SonID[101];//子节点地址
};
int MAXheight=1;int height[101]={0};
int Traversing(IDleave* &ID){//对树进行遍历
    if(ID->SonNum!=0){
        for(int i = 0;i<ID->SonNum;i++){
            ID->SonID[i]->high = ID->high+1;
            if(ID->SonID[i]->high>MAXheight){
                MAXheight = ID->SonID[i]->high;
            }
            Traversing(ID->SonID[i]);//递归
        }
    }
    else{
        height[ID->high] = height[ID->high]+1;
    }
}
int main(){
    int N,M,ID,K,SID;
    IDleave IDmap[101];//用于保存所有节点信息
    scanf("%d %d",&N,&M);
    int i,j;
    if(N==1&&M==0){
        IDmap[1].high =1;
        IDmap[1].SonNum = 0;
    }
    for(i=0;i<M;i++){//M个非叶子节点的信息获取
        scanf("%d %d",&ID,&K);
        IDmap[ID].SonNum = K;
        for(j=0;j<K;j++){
            scanf("%d",&SID);
            IDmap[ID].SonID[j]=&IDmap[SID];//指向子节点的地址
        }
    }
    IDleave* p;
    p = &IDmap[1];
    Traversing(p);
    for(int i = 1;i <MAXheight;i++){
            printf("%d ",height[i]);
    }
    printf("%d\n",height[MAXheight]);
    return 0;
}
 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值