PAT甲级 1006 Sign In and Sign Out

题目:

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目解读

这个题目的大致意思就是,一个机房,每天都会有人来签到,第一个人开门,最后一个人锁门。会给出这个人的ID,某一天到达机房的时间和离开机房的时间,问你,谁是开门的,谁是锁门的。输出这两个人的ID。

按照要求,创建结构体或者是类,然后将数据存放,进行排序即可知道谁是第一个来,谁最后一个走。

AC

#include <iostream>
#include <algorithm>
using namespace std;

int n;
struct ti {
    int h, m, s; // 表示一个时间
};
pair<ti, string> arr[10000];
pair<ti, string> dat[10000];
// 我在这里将人的信息都分开了,分成了两组,第一组:arr,为ID和来的时间,第二组:dat,为ID和走的时间

int main() {
    cin >> n;
    
    for (int i = 0;i < n;i ++) {
        string id;
        int s_h, s_m, s_s, e_h, e_m, e_s;
        // 来的时间的小时,分钟,秒钟, 走的时间的小时,分钟,秒钟
        cin >> id;
        scanf("%d:%d:%d%d:%d:%d", &s_h, &s_m, &s_s, &e_h, &e_m, &e_s); // 格式化输入数据

        ti t;t.h = s_h, t.m = s_m, t.s = s_s;
        ti tt;tt.h = e_h, tt.m = e_m, tt.s = e_s;
        
        // 将他们添加的对应的集合中
        arr[i] = { t, id };
        dat[i] = { tt, id };
    }
    
    // 以来的时间升序排,得到谁是第一个来的
    sort(arr, arr + n, [](pair<ti, string> _1, pair<ti, string> _2){
        if (_1.first.h == _2.first.h) {
            if (_1.first.m == _2.first.m) {
                return _1.first.s < _2.first.s;
            }
            else return _1.first.m < _2.first.m; 
        } 
        else return _1.first.h < _2.first.h; 
    });
    
    cout << arr[0].second << ' ';
    
    // 以走的时间降序排,得到谁是最后一个走的
    sort(dat, dat + n, [](pair<ti, string> _1, pair<ti, string> _2){
        if (_1.first.h == _2.first.h) {
            if (_1.first.m == _2.first.m) {
                return _1.first.s > _2.first.s;
            }
            else return _1.first.m > _2.first.m; 
        } 
        else return _1.first.h > _2.first.h; 
    });
    
    cout << dat[0].second << endl;
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值