Oulipo(KMP)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
问在第二个字符串中能找到几个第一个字符串。
我使用下面这个代码就没过,KMP算法``

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
const int maxn = 1000100;

char p[maxn],s[maxn];
int next[maxn];
int lenp,lens;

int KMP()
{
    int i=0,j=0,ans=0;
    while(i<lenp&&j<lens)
    {
        if(i==-1||p[i]==s[j])
        {
            i++;j++;
        }
        else
        {
            i=next[i];
        }
        if(i==lenp)
        {
            ans++;
            i=next[i];
        }
    }
    return ans;
}

void getnext()
{
    next[0]=-1;
    int i=0,j=-1;
    while(i<lenp)
    {
        if(j==-1||p[i]==p[j])
        {
            i++;j++;
            if(p[i]==p[j])next[i]=next[j];
            else next[i]=j;
        }
        else
        {
            j=next[j];
        }
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",p);
        scanf("%s",s);
        lenp=strlen(p);
        lens=strlen(s);
        getnext();
/*
        for(int i=0;i<lenp;i++)
            cout<<next[i]<<" ";
        cout<<endl;
*/
        int ans=KMP();
        printf("%d\n",ans);
    }
    return 0;
}

ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[10100],b[1000100];
int f[10100];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",a,b);
        memset(f,0,sizeof(f));
        int d=strlen(a),j=0,k=-1;
        f[0]=-1;
        while(j<d)
        {
            if(k==-1||(a[k]==a[j]))
            {
                k++;
                j++;
                f[j]=k;
            }
            else
                k=f[k];
        }
        int l=strlen(b);
        int sum=0,i=0;
        k=0;
        while(i<l)
        {
            if(k==-1||b[i]==a[k])
            {
                k++;
                i++;
                if(k==d)
                {
                    sum++;
                    k=f[k];
                }
            }
            else
                k=f[k];
        }
        printf("%d\n",sum);
    }
}

哈希算法:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
typedef unsigned long long ll;
const int base = 31;
const int maxn = 1000050;

char sub[maxn],str[maxn];
ll a[maxn];
ll hash[maxn];

int main()
{
    int T,i;
    scanf("%d",&T);

    a[0]=1;
    for(i=1;i<maxn;i++)
        a[i]=a[i-1]*base;//次方 

    while(T--)
    {
        memset(sub,0,sizeof(sub));
        memset(str,0,sizeof(str));
        scanf("%s",sub);
        scanf("%s",str);
        int L=strlen(sub);
        int n=strlen(str);

        ll sub_num=0;
        for(i=L-1;i>=0;i--) 
        {
            sub_num=sub_num*base+sub[i];//子字符串的哈希值 
        }

        hash[n]=0;
        for(i=n-1;i>=0;i--)
        {
            hash[i]=hash[i+1]*base+str[i];//从后往前加
        }

        int ans=0;
        for(i=0;i<=n-L;i++)     ///Caution!!! it is (i<=n-L) or (i<n-L+1)
        {
            if(sub_num==hash[i]-hash[i+L]*a[L])//从前往后数 
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值