Oulipo(kmp)

Oulipo(kmp)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

题意: 一次给两个字符串,先给模式串,再给主串,问在主串中能找到几个模式串(可重叠)

思路: kmp模板

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=1e6+100;
char s[N],t[N];//s主,t模式 
int tt,sl,tl,ne[N];
void getnext()
{
	ne[0]=-1;//下标为0的字符前没有字符串,单独处理,赋为-1 
	int i=0,j=-1;
	while(i<tl)
	{
		if(j==-1||t[i]==t[j])
		{
			i++;
			j++;//对应字符匹配,i,j同步向后移 
			ne[i]=j;//赋值 
		}
		else//不匹配 ,i不变,j回溯
		j=ne[j];
	}
}
int kmp()
{
	int i,j=0,sum=0;//j=0初始化在模式串的第一个位置 
	for(i=0;i<sl;i++)//遍历整个主串 
	{
		while(j&&s[i]!=t[j])//顺着不匹配的边走,直到能匹配,最坏的情况j=0 
		j=ne[j];
		if(s[i]==t[j])//匹配成功,下一个位置 
		j++;
		if(j==tl)//在主串中找到了模式串 
		{
			sum++;//总数+1 
			j=ne[j];//下一个位置 //若不可重叠,j=0;
		}
	}
	return sum;
}
int main()
{
	scanf("%d",&tt);
	while(tt--)
	{
		memset(ne,0,sizeof(ne));
		scanf("%s",t);
		scanf("%s",s);
		sl=strlen(s);
		tl=strlen(t);
		getnext();
		printf("%d\n",kmp());
	}
	return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值