PTA甲级-1013 Battle Over Cities c++

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting cit**y1-cit**y2 and cit**y1-cit**y3. Then if cit**y1 is occupied by the enemy, we must have 1 highway repaired, that is the highway cit**y2-cit**y3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

一、题干大意

给出n座城市、m条道路、k座有可能被占领的城市。

请你求出当某座城市被占领后,如果要保持所有的城市联通,至少要新建几条路。

二、题解要点

  • 这题其实是在求联通分量,因为当需要求出新建的马路条数等于连通分量-1;

三、具体实现

/**
*@Author:hhzheng
*@Date:2023/2/21  7:42
*@Filename:PAT甲级1013 Battle Over Cities
*/

#include <cstdio>
#include <algorithm>
using namespace std;
int v[1010][1010];
bool visit[1010];
int n;
void dfs(int node) {
    visit[node] = true;
    for(int i = 1; i <= n; i++) {
        if(visit[i] == false && v[node][i] == 1)
            dfs(i);
    }
}
int main() {
    int m, k, a, b;
    scanf("%d%d%d", &n, &m, &k);
    for(int i = 0; i < m; i++) {
        scanf("%d%d", &a, &b);
        v[a][b] = v[b][a] = 1;
    }
    //对于每一个要考虑的城市都进行一边循环
    for(int i = 0; i < k; i++) {
        //先把每个城市的visit标志置为false表示为未访问
        fill(visit, visit + 1010, false);
        scanf("%d", &a);
        int cnt = 0;
        //被占领的城市设为已访问 这样遍历的时候就不会把它和那些连接它的公路考虑进去
        visit[a] = true;
        //接下来是一个深度优先遍历,但是拆开来了
        //从某个城市出发深度遍历完可以遍历的城市后,说明这些在一次深度优先遍历的城市是一个联通分量
        //此时把再去找那些还没遍历的城市,重复上述的步骤,每次遍历前都计数
        for(int j = 1; j <= n; j++) {
            if(visit[j] == false) {
                dfs(j);
                cnt++;
            }
        }
        //要使所有的城市连接到一起,只需要比联通分量少一条的道路就可以
        printf("%d\n", cnt - 1);
    }
    return 0;
}

总结

总是能想到怎么做,但是有一些细节但关键的操作不知道该怎么进行,所以导致解题的时候受到很大的阻碍,接下来几天针对图的算法再练一练。

https://www.liuchuo.net/archives/2346

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值