PTA甲级-1003 Emergency c++

题目内容

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

一、题干大意

第一行的数依次代表城市数、道路数、起点城市、终点城市 ;第二行的数代表各个城市内的救援队数量;接下来的每行数依次代表起点城市、终点城市、路长。要求是求得起点城市和终点城市有几条最短路径,并记录能最多能聚拢多少救援队。

二、题解要点

  • 总的来说就是找最短路径

三、具体实现

#include <iostream>
#include <algorithm>
using namespace std;

//以下变量分别对应城市数、道路数、起点城市、终点城市 
int n, m, c1, c2;
//是城市之间的邻接矩阵  每个城市的救援队数  最短的路径条数 到达目的地时所聚集的救援队数 
int e[510][510], weight[510], dis[510], num[510], w[510];
//是否已经到过该城市 
bool visit[510];
//不可达距离 
const int inf = 99999999;
int main() {
	//接收城市数、道路数、起点城市、终点城市 
    scanf("%d%d%d%d", &n, &m, &c1, &c2);
    //接收每个城市的救援队人数 
    for(int i = 0; i < n; i++)
        scanf("%d", &weight[i]);
    //fill函数初始化二维函数 默认邻接矩阵都是无穷大  
    fill(e[0], e[0] + 510 * 510, inf);
    //初始化到各个城市的距离 默认无穷大 
    fill(dis, dis + 510, inf);
    //读入城市间道路长度信息 完成邻接矩阵 
    int a, b, c;
    for(int i = 0; i < m; i++) {
        scanf("%d%d%d", &a, &b, &c);
        e[a][b] = e[b][a] = c;
    }
    //设置起点为c1 
    dis[c1] = 0;
    //设置最开始的救援队数 也就是出发城市的救援队数 
    w[c1] = weight[c1];
    
    num[c1] = 1;
    for(int i = 0; i < n; i++) {
        int u = -1, minn = inf;
        for(int j = 0; j < n; j++) {
            if(visit[j] == false && dis[j] < minn) {
                u = j;
                minn = dis[j];
            }
        }
        if(u == -1) break;
        visit[u] = true;
        for(int v = 0; v < n; v++) {
            if(visit[v] == false && e[u][v] != inf) {
           	//当判定dis[u] + e[u][v] < dis[v]的时候,不仅仅要更新dis[v],还要更新num[v] = num[u], w[v] = weight[v] + w[u]; 
		//如果dis[u] + e[u][v] == dis[v],还要更新num[v] += num[u],而且判断一下是否权重w[v]更小,如果更小了就更新w[v] = weight[v] + w[u];
                if(dis[u] + e[u][v] < dis[v]) {
                    dis[v] = dis[u] + e[u][v];
                    num[v] = num[u];
                    w[v] = w[u] + weight[v];
                } else if(dis[u] + e[u][v] == dis[v]) {
                    num[v] = num[v] + num[u];
                    if(w[u] + weight[v] > w[v])
                        w[v] = w[u] + weight[v];
                }
            }
        }
    }
    printf("%d %d", num[c2], w[c2]);
    return 0;
}

总结

这个解法是柳神的,我把链接贴在下边:

https://blog.csdn.net/liuchuo/article/details/52300668

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值