Fire Game FZU - 2150

Fire Game FZU - 2150
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input
The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

编译错误的看下面代码
node(int x, int y): x(x), y(y){}//这条不加会编译错误
Code:

#include <cstdio>
#include <iostream>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
struct node
{
    int x,y;
    node(int x, int y): x(x), y(y){}//这条不加会编译错误
};
const int inf=0x3f3f3f3f;
int n,m;
char mp[15][15];
int vis[15][15];
int coutt[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int dis[15][15];
vector<node>data;
int tt,sum;
int bfs(int x1,int y1,int x2,int y2)
{
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    tt=sum-2;
    if(tt<=0)return 0;
    queue<node>q;
    q.push(node(x1,y1));
    q.push(node(x2,y2));
    vis[x1][y1]=1;
    vis[x2][y2]=1;
    dis[x1][y1]=0;
    dis[x2][y2]=0;
    while(!q.empty())
    {
        node xx=q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int t1=xx.x+coutt[i][0];
            int t2=xx.y+coutt[i][1];
            if(t1>=0&&t1<n&&t2>=0&&t2<m&&!vis[t1][t2]&&mp[t1][t2]=='#')
            {
                dis[t1][t2]=dis[xx.x][xx.y]+1;
                vis[t1][t2]=1;
                tt--;
                q.push(node(t1,t2));
                if(tt==0)
                {
                    return dis[t1][t2];
                }
            }
        }
    }
    return -1;
}

int main()
{
    int T,cass=1;
    scanf("%d",&T);
    while(T--)
    {
        data.clear();
        sum=0;
        scanf("%d %d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%s",mp[i]);
            for(int j=0; j<m; j++)
            {
                if(mp[i][j]=='#')
                {
                    data.push_back(node(i,j));
                    sum++;
                }
            }
        }
        if(sum<=2&&sum>=0)
        {
            printf("Case %d: 0\n",cass++);
            continue;
        }
        int ans=inf;
        for(int i=0; i<data.size(); i++)
        {
            for(int j=i+1; j<data.size(); j++)
            {
                int tmp=bfs(data[i].x,data[i].y,data[j].x,data[j].y);
                if(tmp!=-1)
                {
                    if(ans>tmp)
                        ans=tmp;
                }
            }
        }
        if(ans==inf)
            printf("Case %d: -1\n",cass++);
        else
            printf("Case %d: %d\n",cass++,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值